Upgrade Requirements and Return Policy

  • Customers purchasing an upgrade must have a qualifying older version of a product registered to their user account
  • Our product licensing mechanism will enforce this policy by verifying registration following purchase and will only activate purchased products for purchases that meet the Qualifying Purchase criteria.
  • If you don't have a previously registered qualifying product, you will not be able to register and use the upgrade
  • No returns or refunds will be accepted except where required by law. Customers are expected to review their eligibility before purchase
  • Academic products do not qualify for upgrade pricing

Requirements Specific to Certain Upgrades:


RAD Studio 10.1 Berlin, Delphi 10.1 Berlin, and C++Builder 10.1 Berlin

To check which product versions you are currently registered with, log in to members.embarcadero.com and click My Registered Products.

Upgrade qualifications may be extended to registered users of older versions during promotional offers. See http://www.embarcadero.com/radoffer for current offers.

Qualifying products for all 10.1 Berlin Architect and Ultimate upgrades

Any Architect, Ultimate or Enterprise edition of:

  • Delphi XE6-XE8
  • C++Builder XE6-XE8
  • RAD Studio XE6-XE8

Qualifying products for all 10.1 Berlin Professional and Enterprise upgrades

Any Enterprise or Professional edition of:

  • Delphi XE6-XE8
  • C++Builder XE6-XE8
  • RAD Studio XE6-XE8

Qualifying products for "upgrade from Starter" upgrades

The "upgrade from Starter" upgrade prices are available to registered users of version XE6 or later of Delphi Starter edition or C++Builder Starter Edition.

Upgrade qualifications may be temporarily changed time to time during promotional offers.


Delphi 10.1 Berlin Starter and C++Builder 10.1 Berlin Starter

Delphi 10.1 Berlin and C++Builder 10.1 Berlin Starter upgrade/competitive upgrade pricing is available to owners of any other IDE or software development tool including earlier versions of Delphi, C++Builder, Turbo Delphi, Turbo C++, Turbo Pascal or any other paid or free IDE from any other vendor (such as Visual Studio Express Editions, Lazarus, Eclipse, and others).